OkPy crashes revit on New and Open

I was able to use OkPy normally last week. Now when i try to create a New Tool or Open one of my .okpy files, i gen an unrecoverable error dialog


i tried uninstalling and reinstalling Orkestra and it doesn’t seem to have any effect. Any clue what might have caused this to happen?

Hi there @mclough !
thank you for reporting this.
Has it started happening in the same version of Revit it used to work in ? Did you install any plugins ever since?
Which version is this occurring in ?

this is in 2024.2

OkPy was working with 2024.2 earlier last week. I think i did install a new addin (autodesk Data Exchange).

i reported this in the github: Revit crashes when opening OkPy file or attempting to create new OkPy tool · Issue #228 · OrkestraOnline/Orkestra_Online (github.com)

Hey there @mclough ! this should normally be solved in 1.8.0 . Please let me know when you get a chance to try it out !

@mclough just checking in on this one. Have you had a chance to try?

it didn’t seem to fix the issue by installing or reinstalling the update. i was incidentally in the process of changing computers and 1.8.x seems to be stable for the new computer with a fresh installation of revit.

i haven’t had the opportunity to try a full reinstall of revit on the other computer.

I’ve also encountered some new failures. I’m not sure if all this is somehow related to what i’m trying to do in the scripts.

i get this warning, typically after i’ve been working on a file for a bit, and only after closing okpy. now i get this warning, and clicking OK opens the okpy editor, but i only see the script’s inputs. This behavior occurs when creating a new tool, opening from the recent list, and opening a file by selection.

this seems to clear itself by restarting revit, but also gets cleared by reinstalling orkestra.

Thanks you so much for the very valuable feedback!
We have identified another thing that can trigger a crash : when a folder path for custom UI Inputs doesn’t exist anymore. Do you think you may be pointing at a folder that doesn’t exist anymore in your preference settings?

@mclough would it please be possible to send one of these .okpy files to support@orkestra.online ? It would help us make sure we nail the issue once and for all. Thanks a lot !

This should be fixed in 1.8.1 ! please let us know when you get to try it out.

great news! i haven’t had that second issue occur again, so i didn’t have anything to send.

1 Like

amazing ! thanks so much for helping us identify and figure this one out ! :slight_smile: